Selecting the Default ASP.NET Version – PB Docs 150


Selecting the Default ASP.NET Version

If you installed multiple versions of the .NET Framework on the
target Web server, you should make sure that IIS uses a supported version for PowerBuilder
.NET applications.

You can make this change globally, for all ASP.NET Web site applications, or for individual applications that you deploy to IIS.

The following procedure applies to IIS 5 and 6. In IIS 7 and later, set the .NET Framework
version for the application pool your applications use. For more information, see Configuration Requirements for Windows Vista and Later.

  1. Select Start > Run from the Windows Start menu.
  2. Type InetMgr in the Run dialog box list.
  3. In the left pane of the IIS Manager, expand the local computer node and its Web Sites sub-node.
  4. One of the following:
    • For all new Web sites, right-click the Default Web Site node and select
      Properties.
    • For already deployed projects, expand the Web site node and right-click the .NET application
      that you deployed from PowerBuilder.
  5. Specify the ASP.NET or .NET Framework version.
    • On Windows XP, open the ASP.NET tab and choose the ASP.NET version:
      • For PowerBuilder 12.0 and earlier: 2.0.50727
      • For PowerBuilder 15.0:
        4.0.30319
    • On Windows 7, Windows Vista, and Windows 2008, set the .NET
      Framework version used by your NVO Web service deployment:

      1. In the IIS Manager, open the Application Pools node
        underneath the machine node.
      2. Right-click the PBDotNet4AppPool filter and choose
        Advanced Settings.
      3. Set the .NET Framework Version to
        4.0.

Document get from Powerbuilder help
Thank you for watching.
Was this article helpful?
Subscribe
Notify of
guest
0 Comments
Inline Feedbacks
View all comments
0
Would love your thoughts, please comment.x
()
x